Weird battery life problems

Home Forums Xiaomi Mi4c libra General Discussion Weird battery life problems

This topic contains 8 replies, has 8 voices, and was last updated by  viva1992 1 year, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #11318

    adamuadamu
    Participant

    Hello!
    I’ve been using the TS’s ROMS since the end of 2015 on my mi4c.
    So far, no matter what, I was able to get somewhere between 3h-3h45m SoT; once got 4h30m but it never happened again.
    My battery got worn lately (ie. phone was switching off at about 30%) – ordered a new one, replaced – it got better in terms no surprise at 30% level, but not much better battery life from charge to charge
    So, I thouhgt I’d flash latest xiaomi.eu MIUI ROM to delete all leftovers and so on and reflash CM13.1 to see how battery life changed. Imagine my surprise to discover that I got less than 2h SoT within 12 hours of use! I didn’t install anything new – just flashed MIUI, run it for couple of hours, hated it, reflashed latest CM13.1 by TS and restored my TWRP backup. xda’s BBS show absolutely nothing unusual, about 5% of being awake at screen-off-time which I consider a good result.
    Can that be explained? What I am supposed to do to get back my previous batt life? I hoped to get closer to 5h SoT that some reported to achieve, but it turned out it’s gotten much worse.

    #11354

    Bloodshot
    Participant

    Same here, my phone turned off one time at 10% on time on 15%. I tried to reset it by deleating the battery file with 100% battery and used till it turned off.. had around 25% left. something isnt right

    #11364

    Pawliko
    Participant

    I have same problem.

    #11373

    adamuadamu
    Participant

    well, after investigating and experimenting I didn’t go any further than to do a clean flash. It helped indeed – I’m able to get 3-3h45 SoT within 36 hours

    still no idea what caused this

    #11378

    fanren2b
    Participant

    ts is not work?

    #11447

    Jordison
    Participant

    I’m having the same problems with battery. Phone just drops from 25-30% to 0% and dies.

    #11453

    jones321
    Participant

    I can confirm battery % problem on latest ROM.

    #11518

    soslight
    Participant

    Same issue from a few days before.Turn off at about 25%.Still no idea.
    And wishing TS can solve this.

    #12101

    viva1992
    Participant

    I had the same issue, also the signal problems, so i flashed the firmware: http://www.teamsuperluminal.org/download/ts_libra_miui_v8120_fw_patch-zip/
    The problems were fixed :)

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.