LEx720 cm13 IR blaster can not work?

Home Forums LeEco LE Pro 3 le_zl1 CM13 ROM LEx720 cm13 IR blaster can not work?

This topic contains 6 replies, has 4 voices, and was last updated by  Hr_19 5 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #11862

    gomblie
    Participant

    Hi A problem has been bothering me
    Install the latest cm13-1226 ROM.
    IR blaster is not working properly.
    IR universal TV remote fail.
    What am I to do? wait?ekkilm?

    #11948

    morphic
    Keymaster

    Rename attached file init.uei.sh and copy it to /system/etc folder.
    Then reboot and IR should work.

    If still doesn’t work, please provide logs.
    Take logs:
    1. reboot phone
    2. open IR app
    3. Use syslog app to get logs

    Attachments:
    1. init.uei_.sh_.txt
    #12045

    gomblie
    Participant

    Thank you solved the problem.
    Copy the EUI system
    data/dat/com.uei.quicksetsdk.letv/files folder to cm13
    data/dat/com.uei.quicksetsdk.letv/files Setting permission 755 file 666
    OK IR work.
    still have a question:
    Switch move data Operation cumbersome
    I think the need to optimize.
    Looking forward to the next update.

    #12081

    androcheck
    Participant

    Hi!

    Nice to see that my “InfraredMagic” work finally found its way natively into a ROM so that my Xposed module is not needed to get IR working. Of course it would have been nice if you at least would have given some credit in the release notes. But no offense taken. :-)

    Another question: is the permissive mode necessary because of the IR Blaster fix or is there some other reason?

    If IR is the only reason, you could try to directly activate the IR blaster in the kernel driver (drivers/misc/ir_maxq616.c) instead of writing to the “/sys/remote/enable” sys-file from the ConsumerIrManager/InfraredMagic class (which I guess you do).

    Greetings from Austria,
    john

    #12084

    morphic
    Keymaster

    Nice to see that my “InfraredMagic” work finally found its way natively into a ROM so that my Xposed module is not needed to get IR working. Of course it would have been nice if you at least would have given some credit in the release notes. But no offense taken.

    Ouch! My bad, I forgot.. Sorry. Just added infrared credits to le pro3 cm13 rom page 😉
    And yeah, thanks for the code!

    Another question: is the permissive mode necessary because of the IR Blaster fix or is there some other reason?

    Not because of IR blaster, just pure laziness. I haven’t time/interest to go through all denials.

    If IR is the only reason, you could try to directly activate the IR blaster in the kernel driver (drivers/misc/ir_maxq616.c) instead of writing to the “/sys/remote/enable” sys-file from the ConsumerIrManager/InfraredMagic class (which I guess you do).

    True, it’s based on your code 😛 However, I don’t want to activate it always, only if somebody uses it.

    #12098

    androcheck
    Participant

    However, I don’t want to activate it always, only if somebody uses it.

    Good idea, might save some battery if IR isn’t used at all (at least I guess this was the original intention for including the ir_maxq616 driver in the kernel). 🙂

    #12254

    Hr_19
    Participant

    I couldn’t get the IR blaster working on this ROM. I had Slim6 installed for a while, and I had to copy some file(s) from somewhere in the ROM to somewhere else in the ROM (wish I could be more specific, but I don’t remember), and that made it work. I tried the init file a few posts above, but it didn’t work for me. Are there any other methods? If you want the log, is there a specific event I need to try to put in the log?

    • This reply was modified 5 months, 2 weeks ago by  Hr_19.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.